[RESOLVED] Problems loading inbox

Incident Report for Spruce Health

Postmortem

Some areas of the Spruce application were inaccessible across desktop, web, iOS, and Android from 6:34 AM PT to 6:50 AM PT on July 22, 2026, due to an infrastructure issue.

User Impact during this time:

  • The Spruce inbox was unavailable to patients and providers.

  • Bulk messages and saved messages were unavailable for providers.

  • Inbound calls were not affected.

  • Inbound SMS messages, emails, and faxes were successfully delivered to the Spruce inbox during this time.

We are working to determine the root cause of the service issue and exploring ways to prevent similar incidents in the future.

Posted Jul 22, 2026 - 12:33 PDT

Resolved

Some areas of the Spruce application were inaccessible across desktop, web, iOS, and Android from 6:34 AM PT to 6:50 AM PT on July 22, 2026, due to an infrastructure issue.

‌User Impact during this time:
The Spruce inbox was unavailable to patients and providers.
Bulk messages and saved messages were unavailable for providers.

Inbound calls were not affected. Inbound SMS messages, emails, and faxes were successfully delivered to the Spruce inbox during this time.‌

We are working to determine the root cause of the service issue and exploring ways to prevent similar incidents in the future.
Posted Jul 22, 2026 - 10:35 PDT

Monitoring

We noticed loading issues starting around 13:34 UTC. We identified the issue and implemented a fix. We are seeing the system recover and will continue to monitor to ensure that the system is stable.
Posted Jul 22, 2026 - 06:59 PDT

Investigating

We are investigating an issue with loading leading the inbox in the web and mobile apps.
Posted Jul 22, 2026 - 06:47 PDT
This incident affected: Web App and Mobile Apps.