Users on Comcast/Xfinity reporting issues connecting to Spruce
Incident Report for Spruce Health
Resolved
The external network connectivity issues have been resolved. The service should now be fully accessible for everyone.
Posted Mar 05, 2024 - 14:03 PST
Investigating
We are receiving reports of users on Comcast/Xfinity's internet service being unable to connect to Spruce. The Spruce platform remains operational and this seems to isolated to users on Comcast/Xfinity.

If you are on Comcast/Xfinity, please try connecting through a different internet service provider to reach Spruce. You could try the mobile apps via a cellular network connection in the mean time.

We are actively monitoring the situation and ensuring that the impact is not more widespread. We are also looking for an official report on this to ensure that our assessment is correct.
Posted Mar 05, 2024 - 12:59 PST
This incident affected: Web App.