Inbox actions slow to respond
Incident Report for Spruce Health
Resolved
The platform has stabilized and all inbox actions should be performing normally. If you have any concerns or are seeing something different, please don't hesitate to email us at support@sprucehealth.com or message us in-app using the Spruce Support thread.
Posted Apr 13, 2020 - 10:24 PDT
Monitoring
We have rolled out a fix and are seeing improvements to the overall platform. We will keep monitoring the situation to ensure that performance is back to normal levels and that there are no other issues.
Posted Apr 13, 2020 - 09:24 PDT
Identified
We have identified an issue where we are not optimizing querying of information from the database. This issue compounded as traffic increased causing inbox related actions to slow down. We have a fix we are working to release and will update this status page as soon as the release has rolled out as the situation has improved.
Posted Apr 13, 2020 - 08:56 PDT
Investigating
We are currently investigating an issue where inbox actions such as archive, assign or marking as read are taking long to complete. This issue has no impact to inbound/outbound calls, sms, fax or secure messages.
Posted Apr 13, 2020 - 08:47 PDT
This incident affected: Web App and Mobile Apps.