Inbound MMS and SMS delayed experiencing delays of 15+ minutes
Incident Report for Spruce Health
Resolved
Our telecom provider reported that the issue has been resolved, and all inbound SMS and MMS should no longer be experiencing delays.
Posted Mar 05, 2019 - 08:55 PST
Investigating
Our telecom provider (Twilio) has informed us that all inbound SMS and MMS are experiencing delays of 15 minutes or more before they reach your Spruce inbox. Our engineers are monitoring the situation and ensuring that there is no other impact.

We will update this page as soon as we learn more.
Posted Mar 05, 2019 - 08:32 PST
This incident affected: SMS Routing.