The intermittent performance issues have been resolved.
Posted Jul 24, 2026 - 06:33 PDT
Monitoring
We have implemented a series of fixes to improve system stability and are currently monitoring the system.
Posted Jul 23, 2026 - 14:43 PDT
Update
We have applied some initial fixes to help mitigate the impact, and are seeing some improvement. However, we are still working to identify the root cause of the issue. Our team continues to actively investigate, and we will provide another update as soon as we know more. We apologize for the ongoing inconvenience.
Posted Jul 21, 2026 - 10:48 PDT
Update
We are continuing to investigate this issue.
Posted Jul 20, 2026 - 14:11 PDT
Update
We are continuing to investigate this issue.
Posted Jul 20, 2026 - 12:25 PDT
Investigating
We are currently investigating reports of slowness within the application. Some users may experience delays when loading pages or completing actions. We will provide an update as soon as we have more information.