RESOLVED: Elevated Platform Latency
Incident Report for Spruce Health
Resolved
This incident report was added retroactively to the page on January 23 2020 at 2:30pm PT.

Between 7:55am and 11am PT, on January 22 2020, the Spruce platform experienced periods of elevated latency with the following customer impact:
* Spruce Inbox was slow to load on the web and mobile.
* Calls may have failed during this time with a message to the caller informing them of the unsuccessful call connection.
* Inbound SMS and fax were all successfully received but may have been delayed at times.
* Outbound messages (both SMS and secure) sent during this time period may have been delayed in delivery.

Here are the exact time periods of elevated latency (all times in Pacific Time):
* 7:58-8:00am
* 9:43-9:49am
* 10:03-10:06am
* 10:15-10:21am
* 10:36-11:02am

Spruce engineers have determined that the cause of these periods of elevated latency was an unexpected burst in messaging that put the system under temporary stress. We have since deployed improved throttling behavior that will help during any future bursts in message volume. As always, we will continue to investigate further ways to make Spruce more robust, and we will invest resources as necessary to ensure that Spruce has the best possible safeguards in place for the future.
Posted Jan 22, 2020 - 11:05 PST
Update
We are continuing to investigate this issue.
Posted Jan 22, 2020 - 09:50 PST
Investigating
We are investigating an issue that is impacting inbox performance.
Posted Jan 22, 2020 - 09:49 PST
This incident affected: Web App, Mobile Apps, Phone Call Routing, Fax, and SMS Routing.