Call Failures and SMS delays
Incident Report for Spruce Health
Resolved
As of 00:13 PT on June 16 2020, our platform is no longer experiencing any issues with delayed SMS and call failures. The platform should be fully operational and this incident is now resolved.

If you are experiencing any issues, please don't hesitate to reach out to us at support@sprucehealth.com.
Posted Jun 16, 2020 - 00:13 PDT
Update
Twilio has informed us that they are starting to see recovery in SMS delays and call failures. We will update this page when we have another update from them.
Posted Jun 15, 2020 - 21:46 PDT
Update
We are still waiting for constructive updates from Twilio, who is working closely with their underlying carrier partner to resolve SMS and call related issues via T-Mobile. We will continue to monitor Twilio's incident page for updates and post here as soon as we have them.

We're extremely sorry for the inconvenience here.
Posted Jun 15, 2020 - 18:02 PDT
Monitoring
T-Mobile has posted an update saying they are working through call and data related issues: https://twitter.com/NevilleRay/status/1272650750665953280?s=20
Posted Jun 15, 2020 - 15:31 PDT
Update
It appears that T-Mobile network failures are impacting calls and SMS. Our communications provider is working through this and providing updates to us via this incident on their status page: https://status.twilio.com/incidents/mkf66gvhnsqf

This is an ongoing issue with impact to inbound/outbound calls and delayed inbound/outbound SMS. Specifically, if you try to make a call from the Spruce app or Spruce desk phone, you may get a busy signal or a constant ringing or no ringing sound at all. Inbound calls may fail similarly.

Outbound SMS that providers send to patients may reach patients in a delayed manner. Inbound SMS may reach the Spruce inbox in a delayed manner too.

There is no impact to Spruce secure messaging. If a patient or provider, however, is prompted to log in and requires a verification code to log in, the 2FA verification code may reach their phone in a delayed manner.
Posted Jun 15, 2020 - 14:19 PDT
Identified
Major carriers (T-Mobile, ATT, Verizon and Sprint) are experiencing outages in various parts of the USA that is in turn impacting the ability to make and receive calls on Spruce. Our underlying communications provider has also reported an outage on SMS and calls. We saw this issue start around 11:45am PT on June 15 2020.

Consequently, the following experiences may be impacted for some customers:
- Inbound and outbound phone call failures
- Delay in receiving SMS into the Spruce inbox
- Delay in receiving verification codes when attempting to log in

Here's a Business Insider article talking about this as well: https://www.businessinsider.com/verizon-sprint-att-t-mobile-service-down-some-areas-us-2020-6

We are monitoring the situation and will provide updates as soon as we have them.
Posted Jun 15, 2020 - 13:13 PDT
This incident affected: Phone Call Routing and SMS Routing.