[RESOLVED] Call transfers from VoIP desk phones not working
Incident Report for Spruce Health
Resolved
The root cause of this outage was the deployment of new code that attempted to manage the transferring of calls to international numbers. The code incorrectly made the assumption that the “to” identifier for the transfer was always a phone number and attempted to parse it as such. In reality this “to” information can also be SIP and Client identifiers. Failing to parse the numbers and treating that failure as a hard failure for the call resulted in the transfer flows failing.
Posted Aug 07, 2024 - 08:07 PDT
Identified
From 5:03 AM PT to 7:56 AM PT on August 7, 2024, call transfers from VoIP desk phones failed to complete and resulted in an error being reported to the user initiating the call transfer.

No other inbound/outbound calls were impacted during this time. The rest of the platform continued to operate as intended.
Posted Aug 07, 2024 - 07:12 PDT
This incident affected: Phone Call Routing.