Degraded SMS functionality
Incident Report for Spruce Health
Resolved
Our telecommunications provider confirmed all systems to be operational at 7:44pm. During this incident, outbound SMS from Spruce was delayed in some instances from 5pm PT to 5:50pm PT. Users may not have been able to log in to Spruce if verification code was required between 5pm PT and 5:50pm PT. All other aspects of Spruce were functional during this time.
Posted Aug 17, 2023 - 19:50 PDT
Update
While we are not seeing any issues with outbound SMS, our telecommunications provider continues to report degraded functionality. So we'll continue to monitor on our end.
Posted Aug 17, 2023 - 18:42 PDT
Monitoring
Outbound SMS looks all caught up at this point with no delays in sending SMS. We'll continue to monitor to see if the issue persists and wait until we have received confirmation from our telecommunications provider that SMS is functional on their end.
Posted Aug 17, 2023 - 17:52 PDT
Identified
Users may not be able to log in to Spruce if they are waiting on the verification code since SMS functionality is degraded.

Our telecommunications provider is experiencing issues with SMS functionality which in turn is impacting Spruce's ability to send SMS.
Posted Aug 17, 2023 - 17:43 PDT
Investigating
We are seeing elevated errors on the system when attempting to send SMS from Spruce. Our telecommunications infrastructure provider is reporting an issue in the SMS functionality which corresponds to the timeline of errors on our end.

Outbound SMS is definitely impacted given that we are seeing errors. All outbound SMS that was sent from the Spruce app will eventually be delivered when our telecommunications provider's systems are operational again.
It is unclear if inbound SMS to Spruce is impacted.

No other functionality on Spruce has been identified to be impacted at this point.
Posted Aug 17, 2023 - 17:39 PDT
This incident affected: SMS Routing.