Issues with inbound and outbound fax delivery.
Incident Report for Spruce Health
Resolved
The issue with faxes has been resolved.
Posted Sep 15, 2023 - 12:59 PDT
Investigating
Our fax provider is currently experiencing issues with inbound and outbound faxes. We will continue to monitor and update as more information is available from https://status.phaxio.com
Posted Sep 15, 2023 - 11:55 PDT
This incident affected: Fax.