Call connectivity issues
Incident Report for Spruce Health
Resolved
Our telecommunications infrastructure provider is seeing recovery on their end. Outbound and inbound calls should be fully functional at this point.
Posted May 18, 2023 - 18:27 PDT
Investigating
Some providers may be experiencing call connectivity issues due to failures on our underlying telecommunications provider's end. We are closely monitoring the situation and will post updates here.
Posted May 18, 2023 - 17:00 PDT
This incident affected: Phone Call Routing.