Search & Contact Filters experiencing intermittent errors and slowness
Incident Report for Spruce Health
Resolved
We identified the reason for performance degradation to be an imbalance of data spread across the cluster. We have since resolved this issue and ensured that all stale search results have been cleared.

The system is fully operational at this point.
Posted Sep 25, 2023 - 16:48 PDT
Investigating
Users may be experiencing degraded performance for the following actions:
- Searching for contacts or conversations: may be giving errors, returning results in a delayed manner or returning stale results
- Creating conversations: maybe return errors or experiencing a lag when searching for contacts
- Sending bulk messages: may be experiencing a lag where stuck in Processing state for a while or just taking longer to complete
- Opening contact lists: may be returning errors or experiencing a lag in returning results

Phone calls, video calls, exchanging messages (fax, secure, email or SMS) is NOT impacted and operating normally.
Posted Sep 25, 2023 - 14:32 PDT
This incident affected: Web App and Mobile Apps.