Call connectivity issues with Verizon
Incident Report for Spruce Health
Resolved
The issue was resolved around 7:45am PT on July 26 as per a statement from Verizon.
Posted Jul 26, 2023 - 08:00 PDT
Identified
Some users may be experiencing call connectivity issues due to an outage with Verison wireless network operator. Users may get a "all circuits are busy" message when placing a call. All other parts of the Spruce system are functioning normally. We are closely monitoring the situation and will post updates here.
Posted Jul 26, 2023 - 06:57 PDT
This incident affected: Phone Call Routing.