Partial application outage
Incident Report for Spruce Health
Postmortem

This incident involved several minutes of partial service outage related to a production database dying unexpectedly (thought to be hardware failure at infrastructure provider), forcing a live switch to the secondary database. The service recovered as expected, very quickly. Conversation loading was temporarily affected, but incoming calls and messages (and other Spruce functions) were unaffected. This automatic recovery in the event of failure is already the intended function of the contingency planning for this type of extremely rare event. While we constantly seek to improve system redundancy and reliability, there are no further action items planned at this time related to this type of occurrence.

Posted Jan 06, 2023 - 17:17 PST

Resolved
All services are now fully operational.
Posted Sep 27, 2021 - 14:42 PDT
Monitoring
There was an issue with a primary database, but it is now back up. The service is recovering.
Posted Sep 27, 2021 - 14:31 PDT
Investigating
We are currently seeing a service interruption with the application and are investigating. Incoming phone calls and messages are unaffected.
Posted Sep 27, 2021 - 14:26 PDT
This incident affected: Web App and Mobile Apps.