Issues with inbound calls.
Incident Report for Spruce Health
Resolved
This incident has been resolved.
Posted Mar 22, 2022 - 12:04 PDT
Monitoring
The issue seems to have been resolved by the provider.
Posted Mar 22, 2022 - 10:07 PDT
Update
Outbound calls are functional at this time. So if a call drops when received, you should be able to place an outgoing call to the phone number to successfully connect with the caller.
Posted Mar 22, 2022 - 09:49 PDT
Investigating
Our telephony provider is currently experience issues that are affecting some inbound calls. They are investigating and we will update as we know more.
Posted Mar 22, 2022 - 09:30 PDT
This incident affected: Phone Call Routing.