We have completed the database updates for the night. Everything went fairly smoothly and the system is full operational based on our monitoring.
We experienced two brief periods of outages: - 01:52:00 am PT - 02:00:00 am PT - 02:07:15 am PT - 02:16:30 am PT
Users might have been unable to log in, access their inbox and contacts, experienced delivery delays for SMS and FAX messages, and inbound/outbound call disruptions during that time. We did our best to keep those windows as short as possible.
During the upgrade, we enabled the Backup System to ensure organizations continued receiving notifications for inbound activity. Now that the maintenance is complete, the primary systems are fully restored, and the Backup System is no longer needed for this purpose.
Thank you for your patience, and if you have any questions, please email us at support@sprucehealth.com or write into your Spruce Support thread in app.
Posted Mar 17, 2025 - 02:38 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 17, 2025 - 01:00 PDT
Scheduled
We will be upgrading our family of databases on March 17 between 1AM PT and 3AM PT. We expect brief periods (likely 2-5 minutes) of outages as we upgrade the core databases during this window. We will be starting with non-critical databases, ensuring that all is good, and then moving over to the critical databases during this time. A member of our engineering team will be online and closely monitoring the system to ensure smooth functioning as we upgrade the series of databases.
During this maintenance window, users may be unable to log in, see all contacts, access their inbox, and experience delivery delays for FAX and SMS messages for brief 2-5 minute periods. Inbound/outbound calls may also be impacted during this time. We will do our best to keep these windows as short as possible. We will be activating the Backup System while upgrading the critical databases to ensure that organizations are notified of inbound activity during this time. Please sign up for notifications from the Backup System under Settings > Backup System in the Spruce app, if you haven’t already.
We will update this page as we are making progress on the database updates.
Posted Mar 06, 2025 - 06:21 PST
This scheduled maintenance affected: Web App, Mobile Apps, Phone Call Routing, Fax, SMS Routing, Video Calling, Spruce app notifications, Integrations, and API.