Issue with outbound faxes

Incident Report for Spruce Health

Resolved

The issue with outbound faxes is now resolved.
Posted Dec 08, 2025 - 16:32 PST

Investigating

Some outbound faxes are currently failing to send due to an issue with our fax provider. We're monitoring and will update as we know more.
Posted Dec 08, 2025 - 15:23 PST
This incident affected: Fax.