Search & Contact Filters experiencing intermittent errors and slowness
Incident Report for Spruce Health
Resolved
System is fully operational now, with all search results having caught up. We're really sorry for the inconvenience caused here and have decided to operate with extra capacity to ensure that the system continues to operate normally moving forward.
Posted May 01, 2023 - 15:28 PDT
Monitoring
Search results and contacts are now loading without any errors. We are working to get search results to reflect latest results. Users should no longer have any issues creating conversations, sending bulk messages or opening contact lists.

Phone calls, video calls, exchanging messages (fax, secure, email or SMS) are NOT impacted and operating normally.

Will post an update as soon as we have search results all caught up.
Posted May 01, 2023 - 15:00 PDT
Update
We continue to actively work on the issue. We will post another update in another hour here as we assess progress of the fix.
Posted May 01, 2023 - 13:52 PDT
Identified
We have identified the reason for the degraded performance and are actively working on resolving the issue.
Posted May 01, 2023 - 12:32 PDT
Investigating
Users may be experiencing degraded performance for the following actions:
- Searching for contacts or conversations: may be giving errors or returning results in a delayed manner or returning stale results
- Creating conversations: maybe return errors or experiencing a lag when searching for contacts
- Sending bulk messages: may be experiencing a lag where stuck in Processing state for a while or just taking longer to complete
- Opening contact lists: may be returning errors or experiencing a lag in returning results

Phone calls, video calls, exchanging messages (fax, secure, email or SMS) is NOT impacted and operating normally.

We have identified the reason for the degraded performance and are actively working on resolving the issue.
Posted May 01, 2023 - 12:12 PDT
This incident affected: Web App and Mobile Apps.