Spruce application issues

Incident Report for Spruce Health

Resolved

This incident has been resolved.
Posted Jul 02, 2026 - 16:47 PDT

Monitoring

We identified an issue with our cloud service provider. We have taken action to resolve the issue and are now monitoring to ensure the Spruce application is stable.
Posted Jul 02, 2026 - 15:41 PDT

Investigating

We are currently investigating an issue that has caused the web and mobile applications to fail to load intermittently.
Posted Jul 02, 2026 - 13:57 PDT
This incident affected: Web App and Mobile Apps.