Spruce platform issues

Incident Report for Spruce Health

Resolved

The issue has been resolved, and the platform is fully functional. Impact occurred between 11:33 AM and 11:48 AM PT. We’ve identified the root cause and will be discussing ways to reduce the likelihood of similar issues in the future.
Posted Oct 29, 2025 - 21:18 PDT

Monitoring

The issue has been resolved, and the platform is currently functional. Impact occurred between 11:33 AM and 11:48 AM PT. We’re continuing to investigate the root cause and will monitor closely in case the issue reoccurs.
Posted Oct 28, 2025 - 11:58 PDT

Investigating

We're currently investigating issues accessing the Spruce platform. We're investigating and will update this page as we learn more
Posted Oct 28, 2025 - 11:49 PDT
This incident affected: Web App, Mobile Apps, Phone Call Routing, Fax, and SMS Routing.