[RESOLVED] Spruce App inaccessible on web
Incident Report for Spruce Health
Resolved
The system has fully recovered and the webapp is back to being monitored for its availability and health via the automated systems that we had in place.
Posted Nov 25, 2020 - 15:03 PST
Update
We're still monitoring the situation to ensure that the ongoing AWS incident doesn't have any impact on our platform. The platform is operating normally.
Posted Nov 25, 2020 - 12:11 PST
Monitoring
The webapp is fully operational now, albeit with manual tasks running to service requests. We are waiting for AWS to resolve the issue on their end so that we can continue to rely on the automated mechanisms in place to monitor the availability and overall health of the web application.

We will continue to monitor the platform on our end and await updates from AWS.
Posted Nov 25, 2020 - 10:57 PST
Identified
Users should be able to load the web app now.

An underlying issue with our cloud service provider, Amazon Web Services (AWS), has resulted in the tasks that run the web application being marked as unhealthy and thereby being killed. AWS is having trouble automatically bringing the tasks back up, an issue they are actively working on as part of a widespread incident.

In the mean time, we were able to manually bring up tasks to continue to restore service and are working to scale the number of manual tasks such that service is restored even if in a degraded fashion.

We will continue to work on the issue and provide an update here as soon as we have completely restored the platform.
Posted Nov 25, 2020 - 10:06 PST
Update
If you have Spruce running in a particular tab in the browser on your computer, then it should continue to work. If you attempt to load the app in a new tab or a different browser or for the first time, then you will not be able to do so currently.
Posted Nov 25, 2020 - 09:25 PST
Update
You can continue to use Spruce on mobile apps (iOS and Android) both as a patient and provider. We would recommend that you switch to your mobile apps for the time being until further notice.
Posted Nov 25, 2020 - 09:13 PST
Investigating
The Spruce app is currently inaccessible on the web. The system is fully operational on mobile apps along with phone call and SMS functionality. We are investigating as we speak and will keep you posted here as soon as we have an update.
Posted Nov 25, 2020 - 08:43 PST
This incident affected: Web App.