Intermittent call failures

Incident Report for Spruce Health

Resolved

Our partner has resolved the issue. All inbound and outbound phone calls are expected to operate normally.
Posted Mar 31, 2025 - 12:09 PDT

Monitoring

Our telecommunications provider has implemented a fix, and we started seeing improvements around 9:45am PT. We are continuing to monitor the situation.
Posted Mar 31, 2025 - 10:31 PDT

Identified

Our telecommunications partner is experiencing issues with call routing. This has resulted in the inability to make or receive calls for some Spruce users. This issue started on March 31, 2025 around 8:10 A.M. PT and is ongoing.
Posted Mar 31, 2025 - 08:10 PDT
This incident affected: Phone Call Routing.