Delayed push notifications
Incident Report for Spruce Health
Resolved
This incident has been resolved.
Posted Jun 13, 2023 - 15:56 PDT
Update
AWS has marked their incident as resolved, and all seems to be operating normally on our end.
Posted Jun 13, 2023 - 15:55 PDT
Monitoring
Push notifications have all caught up. We will keep this ticket open until we have confirmation from AWS that the issue is resolved. We are no longer seeing any delays in processing push notifications.
Posted Jun 13, 2023 - 13:49 PDT
Investigating
Push notifications are delayed due to an ongoing issue with our underlying infrastructure provider, Amazon Web Services (AWS). We have a workaround to resolve the delayed push notifications despite the ongoing AWS issue, and are working to deploy this workaround.

Mobile apps may receive push notifications for inbound and outbound messages in a delayed manner. The web application may refresh the state of the inbox in a delayed manner.
Posted Jun 13, 2023 - 12:51 PDT
This incident affected: Spruce app notifications.