Delayed SMS delivery to AT&T phone numbers
Incident Report for Spruce Health
Resolved
Our telecom partner updated us last evening around 7:27pm (October 19) that the issue was resolved on their end and they were no longer seeing delays in sending SMS to AT&T.
Posted Oct 19, 2022 - 19:27 PDT
Update
Our telecom partner just posted an update saying that they continue to experience messaging sending delays and they are working closely with their partner to resolve the issue. They will post an update soon, likely in the next 6-8 hours on this matter.
Posted Oct 19, 2022 - 17:10 PDT
Monitoring
Our underlying telecommunications infrastructure provider is experiencing SMS delivery delays when when sending messages to AT&T phone numbers. The message may appear as sent in your Spruce application, but may take minutes to get to the recipient.

This incident with our underlying provider is also impacting verification code delivery over SMS. So if a patient or provider tries to create an account or log in, and their cell phone number is with AT&T, they may not get the verification code for minutes. In this case, it is likely best for the user to try the "Call me with code" option accessible on all platforms.

We are actively monitoring this incident and will post an update as soon as we have one.
Posted Oct 19, 2022 - 14:08 PDT
This incident affected: SMS Routing.