Service Disruption: Calls
Incident Report for Spruce Health
Resolved
All services are operating as expected.
Posted Nov 05, 2018 - 12:05 PST
Update
We are seeing far fewer failed calls as we closely monitor the situation; however, our telecom provider continues to see intermittent failures, they are continuing to work on a solution that will resolve these issues.
Posted Nov 05, 2018 - 11:18 PST
Update
We continue to see intermittent inbound and outbound call failures. We are waiting on an update from our telecom provider, who is still investigating the issue.
Posted Nov 05, 2018 - 09:43 PST
Identified
Our telecom provider is reporting elevated failure rates for incoming and outgoing phone calls. We are actively monitoring the situation and will report details as we know them. Spruce Inbox and fax functionality is not affected, and is operating normally.
Posted Nov 05, 2018 - 08:47 PST
This incident affected: Phone Call Routing.