Spruce experiencing issues with outbound calls from the android mobile app
Incident Report for Spruce Health
Postmortem

Summary

At 8:23am PT, we released software that resulted in outbound calls from the Android app failing to work. This was due to software that was incompatible with the latest version of the Android app. We identified the issue at 9:04am PT and quickly root caused it to the software rollout. We deployed a fix at 9:08am PT. Outbound calls on the Spruce Android app were non-functional for customers running the latest version of the app from 8:23am PT - 9:08am PT (45 minutes).

Outbound calling from desk phones, iOS or web-apps were not impacted. No other aspect of the system was impacted.

We are internally discussing ways to reduce the likelihood of incompatible software rollouts like the one that happened today. We understand how important it is for providers to be able to place outbound calls from all platforms at all times, and we’re very sorry for the inconvenience and the business impact here.

Posted Nov 03, 2022 - 19:51 PDT

Resolved
This incident has been resolved.
Posted Nov 03, 2022 - 09:10 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 03, 2022 - 09:09 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 03, 2022 - 09:06 PDT
Investigating
We are investigating an issue with outbound calls from the android mobile app
Posted Nov 03, 2022 - 09:04 PDT
This incident affected: Mobile Apps.