SMS delays from toll free numbers
Incident Report for Spruce Health
Resolved
This issue was reported resolved by Twilio at 12:24pm PST
Posted Feb 13, 2019 - 12:24 PST
Investigating
Our telecom partner Twilio has reported that SMS from toll free numbers are currently delayed. They're currently investigating the issue.
Posted Feb 13, 2019 - 10:04 PST
This incident affected: SMS Routing.